Shimmer node installing from SWARM don t recognice INX Dashboard

  • I install shimmer hornet node from swarm and INX dahsboard don t play.

    I install shimmer node and is ACTIVE


    I install INX dashboard and is active


    I go INX Dashboard configuration to put ¨¨ (its my node adress).

    NO VALID shimmer INX adress try again

    Why i cant put my adress in this window. But Dashboard is active

    I need explications please to execute shimmer node. I cant play https://xxxxx,es:4567 in any browser. But INX dash and participation are ACTIVE like node.

    Regards. Luis

  • As I wrote before, the easiest way would be to disable the INX dashboard in the proxy settings. This ensures that the dashboard can be called up again via the URL that is defined in Hornet (Shimmer).

    I will take the INX settings under advanced settings with the next update so that there is less confusion.

  • I can t play dashboard with yours explains. I see the active dash but i can t see in the browser. Could you take me any photo of the sreens in the configuration please. or any write menu for to see where is the mistake


  • Hi!

    Okay, first please go to the proxy settings and select 2) Proxy Configuration. Then go to 5) Advanced Settings and there you select 2) INX-Dashboard [SHIMMER] Proxy Settings and then please make sure that 1) Enable INX-Dashboard is set for you.

    Then go back and select 3) Hornet [SHIMMER] Proxy Settings. Please make sure that your domain is stored with the corresponding port, e.g. Finally, unless you are automatically prompted by the installer, go back and select 4) Proxy Installer from the main proxy menu and then 1) Install/Deploy The Proxy.

    Once the process is successful, you can access your Dashboard & API normally using the address set in 3) Hornet [SHIMMER] Proxy Settings.

    The options available in 2) INX-Dashboard [SHIMMER] Proxy Settings are only useful if you want to separate the API and the Dashboard, e.g. have the Dashboard running explicitly on a different domain or port.

  • Yes, if you want to use the dashboard, the INX dashboard must be installed. Only whether you want to have everything under one url/port or split it into two different ones is possible with the settings. Most users will want to do everything via the actual Hornet URL, so I have now moved the menu accordingly to create less confusion there.

  • No run: 502 bad gateway


    It turned out that there is an error with the generation of an identity in the versions rc.3 and rc.4. I have already informed the Hornet team and as soon as an update is available I will update the builds for Hornet, after that you can do a manual Hornet update and then the node should work.

    I'll let you know here as soon as it's available.

  • magnetron  Luis

    Okay, the bug has been fixed and I have built the new binaries for you. Please perform a Hornet update via the menu once, then it should work again. The binary for arm (rpi4) will also be available in a few minutes.

  • Since I already told you not to use port 445, please change the port and for the dashboard you need to install the inx plugin, but you don't need to set up the proxy for the dashboard itself, just the configuration for hornet.

  • Please don't change the inx-address, this is only for special cases!

    You need to change the port in the proxy configuration. If you're not using subdomains and want to use your domain for (IOTA) Hornet and (Shimmer) Hornet you need different ports e.g. (IOTA) Hornet = 443 and (Shimmer) Hornet = 444.

    But I also told you that I would recommend using subdomains so that you can use port 443 for both nodes.

  • Is a lot of problem to install a shimmer node. I need put my node for the iota community but is impossible. Is very problematic.

    There isn t a guide for to install my shimmer node without any problem?

    Is for the community. i don t earn anything.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!